CVE-2020-11017

NameCVE-2020-11017
DescriptionIn FreeRDP less than or equal to 2.0.0, by providing manipulated input a malicious client can create a double free condition and crash the server. This is fixed in version 2.1.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freerdp (PTS)stretch1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3vulnerable
stretch (security)1.1.0~git20140921.1.440916e+dfsg1-13+deb9u1vulnerable
freerdp2 (PTS)buster2.0.0~git20190204.1.2693389a+dfsg1-1+deb10u1vulnerable
bullseye, sid2.1.2+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freerdpsource(unstable)(unfixed)
freerdp2source(unstable)2.1.1+dfsg1-1

Notes

[buster] - freerdp2 <no-dsa> (Minor issue)
[stretch] - freerdp <no-dsa> (Minor issue)
[jessie] - freerdp <no-dsa> (Minor issue)
https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-q5c8-fm29-q57c

Search for package or bug name: Reporting problems