CVE-2020-11041

NameCVE-2020-11041
DescriptionIn FreeRDP less than or equal to 2.0.0, an outside controlled array index is used unchecked for data used as configuration for sound backend (alsa, oss, pulse, ...). The most likely outcome is a crash of the client instance followed by no or distorted sound or a session disconnect. If a user cannot upgrade to the patched version, a workaround is to disable sound for the session. This has been patched in 2.1.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freerdp (PTS)stretch1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3vulnerable
stretch (security)1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4vulnerable
freerdp2 (PTS)buster2.0.0~git20190204.1.2693389a+dfsg1-1+deb10u2vulnerable
bullseye, sid2.2.0+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freerdpsource(unstable)(unfixed)
freerdp2source(unstable)2.1.1+dfsg1-1

Notes

[buster] - freerdp2 <no-dsa> (Minor issue)
[stretch] - freerdp <no-dsa> (Minor issue)
https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-w67c-26c4-2h9w

Search for package or bug name: Reporting problems