CVE-2020-11076

NameCVE-2020-11076
DescriptionIn Puma (RubyGem) before 4.3.4 and 3.12.5, an attacker could smuggle an HTTP response, by using an invalid transfer-encoding header. The problem has been fixed in Puma 3.12.5 and Puma 4.3.4.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2398-1
NVD severitymedium
Debian Bugs972102

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puma (PTS)stretch3.6.0-1vulnerable
stretch (security)3.6.0-1+deb9u1fixed
buster3.12.0-2+deb10u1vulnerable
bullseye, sid4.3.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pumasourcestretch3.6.0-1+deb9u1DLA-2398-1
pumasource(unstable)4.3.6-1972102

Notes

[buster] - puma <no-dsa> (Minor issue)
https://github.com/puma/puma/security/advisories/GHSA-x7jg-6pwg-fx5h
https://github.com/puma/puma/commit/f24d5521295a2152c286abb0a45a1e1e2bd275bd

Search for package or bug name: Reporting problems