CVE-2020-11087

NameCVE-2020-11087
DescriptionIn FreeRDP less than or equal to 2.0.0, there is an out-of-bound read in ntlm_read_AuthenticateMessage. This has been fixed in 2.1.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3606-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freerdp2 (PTS)bullseye2.3.0+dfsg1-2+deb11u1fixed
bookworm2.10.0+dfsg1-1fixed
trixie2.11.5+dfsg1-1fixed
sid2.11.7+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freerdpsource(unstable)(unfixed)
freerdp2sourcebuster2.3.0+dfsg1-2+deb10u3DLA-3606-1
freerdp2source(unstable)2.1.1+dfsg1-1

Notes

https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-84vj-g73m-chw7

Search for package or bug name: Reporting problems