CVE-2020-11612

NameCVE-2020-11612
DescriptionThe ZlibDecoders in Netty 4.1.x before 4.1.46 allow for unbounded memory allocation while decoding a ZlibEncoded byte stream. An attacker could send a large ZlibEncoded byte stream to the Netty server, forcing the server to allocate all of its free memory to a single decoder.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2364-1, DSA-4885-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netty (PTS)buster1:4.1.33-1+deb10u2fixed
buster (security)1:4.1.33-1+deb10u4fixed
bullseye1:4.1.48-4+deb11u1fixed
bullseye (security)1:4.1.48-4+deb11u2fixed
bookworm1:4.1.48-7fixed
bookworm (security)1:4.1.48-7+deb12u1fixed
sid, trixie1:4.1.48-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nettysourcestretch1:4.1.7-2+deb9u2DLA-2364-1
nettysourcebuster1:4.1.33-1+deb10u2DSA-4885-1
nettysource(unstable)1:4.1.48-1

Notes

[jessie] - netty <ignored> (OOM DoS with fix/mitigation involving new API; too intrusive to backport due to more limited 3.x buffer API)
https://github.com/netty/netty/issues/6168
https://github.com/netty/netty/pull/9924
https://github.com/netty/netty/commit/1543218d3e7afcb33a90b728b14370395a3deca0

Search for package or bug name: Reporting problems