CVE-2020-11653

NameCVE-2020-11653
DescriptionAn issue was discovered in Varnish Cache before 6.0.6 LTS, 6.1.x and 6.2.x before 6.2.3, and 6.3.x before 6.3.2. It occurs when communication with a TLS termination proxy uses PROXY version 2. There can be an assertion failure and daemon restart, which causes a performance loss.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs956307

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
varnish (PTS)jessie (security), jessie4.0.2-1+deb8u1fixed
stretch (security), stretch5.0.0-7+deb9u2fixed
buster, buster (security)6.1.1-1+deb10u1vulnerable
bullseye, sid6.4.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
varnishsource(unstable)6.4.0-1956307
varnishsourcejessie(not affected)
varnishsourcestretch(not affected)

Notes

[buster] - varnish <postponed> (Can be fixed along in next DSA)
[stretch] - varnish <not-affected> (Only affects 6.x)
[jessie] - varnish <not-affected> (Only affects 6.x)
https://varnish-cache.org/security/VSV00005.html#vsv00005
https://github.com/varnishcache/varnish-cache/commit/2d8fc1a784a1e26d78c30174923a2b14ee2ebf62

Search for package or bug name: Reporting problems