CVE-2020-11724

NameCVE-2020-11724
DescriptionAn issue was discovered in OpenResty before 1.15.8.4. ngx_http_lua_subrequest.c allows HTTP request smuggling, as demonstrated by the ngx.location.capture API.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2283-1, DSA-4750-1
NVD severitymedium
Debian Bugs964950

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)stretch1.10.3-1+deb9u4vulnerable
stretch (security)1.10.3-1+deb9u5fixed
buster, buster (security)1.14.2-2+deb10u3fixed
bullseye, sid1.18.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsourcestretch1.10.3-1+deb9u5DLA-2283-1
nginxsourcebuster1.14.2-2+deb10u3DSA-4750-1
nginxsource(unstable)1.18.0-5964950

Notes

https://github.com/openresty/lua-nginx-module/commit/9ab38e8ee35fc08a57636b1b6190dca70b0076fa (ngx_lua 0.10.17, with tests)
https://github.com/openresty/openresty/commit/4e8b4c395f842a078e429c80dd063b2323999957 (ngx_lua 0.10.15)
nginx packages include ngx_lua in debian/modules/

Search for package or bug name: Reporting problems