CVE-2020-11989

NameCVE-2020-11989
DescriptionApache Shiro before 1.5.3, when using Apache Shiro with Spring dynamic controllers, a specially crafted request may cause an authentication bypass.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2273-1
NVD severityhigh
Debian Bugs988728

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
shiro (PTS)stretch1.3.2-1vulnerable
stretch (security)1.3.2-1+deb9u2fixed
buster, bullseye1.3.2-4vulnerable
bookworm, sid1.3.2-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
shirosourcestretch1.3.2-1+deb9u1DLA-2273-1
shirosource(unstable)1.3.2-5988728

Notes

[bullseye] - shiro <no-dsa> (Minor issue)
[buster] - shiro <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2020/06/22/1
https://github.com/apache/shiro/pull/211
https://issues.apache.org/jira/browse/SHIRO-753
The original CVE-2020-1957 adressed in 1.5.2 introduced an encoding issue
which can (security wise) be exploited, resulting in a 1.5.3 release. This
CVE is closely related to CVE-2020-1957.

Search for package or bug name: Reporting problems