CVE-2020-12278

NameCVE-2020-12278
DescriptionAn issue was discovered in libgit2 before 0.28.4 and 0.9x before 0.99.0. path.c mishandles equivalent filenames that exist because of NTFS Alternate Data Streams. This may allow remote code execution when cloning a repository. This issue is similar to CVE-2019-1352.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgit2 (PTS)jessie0.21.1-3vulnerable
jessie (security)0.21.1-3+deb8u1vulnerable
stretch0.25.1+really0.24.6-1vulnerable
buster0.27.7+dfsg.1-0.2vulnerable
bullseye, sid0.28.5+dfsg.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgit2source(unstable)0.28.4+dfsg.1-2

Notes

[buster] - libgit2 <no-dsa> (Minor issue; only problematic when used on NTFS like filesystem)
[stretch] - libgit2 <no-dsa> (Minor issue; only problematic when used on NTFS like filesystem)
[jessie] - libgit2 <no-dsa> (Minor issue; only problematic when used on NTFS like filesystem)
https://github.com/libgit2/libgit2/commit/3f7851eadca36a99627ad78cbe56a40d3776ed01
https://github.com/libgit2/libgit2/commit/e1832eb20a7089f6383cfce474f213157f5300cb

Search for package or bug name: Reporting problems