CVE-2020-12387

NameCVE-2020-12387
DescriptionA race condition when running shutdown code for Web Worker led to a use-after-free vulnerability. This resulted in a potentially exploitable crash. This vulnerability affects Firefox ESR < 68.8, Firefox < 76, and Thunderbird < 68.8.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2205-1, DLA-2206-1, DSA-4678-1, DSA-4683-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid81.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1fixed
stretch (security)68.12.0esr-1~deb9u1fixed
buster68.10.0esr-1~deb10u1fixed
buster (security)68.12.0esr-1~deb10u1fixed
bullseye68.11.0esr-1fixed
sid78.3.0esr-2fixed
thunderbird (PTS)stretch1:68.10.0-1~deb9u1fixed
stretch (security)1:68.12.0-1~deb9u2fixed
buster1:68.10.0-1~deb10u1fixed
buster (security)1:68.12.0-1~deb10u1fixed
bullseye, sid1:68.12.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)76.0-1
firefox-esrsourcejessie68.8.0esr-1~deb8u1DLA-2205-1
firefox-esrsourcestretch68.8.0esr-1~deb9u1DSA-4678-1
firefox-esrsourcebuster68.8.0esr-1~deb10u1DSA-4678-1
firefox-esrsource(unstable)68.8.0esr-1
thunderbirdsourcejessie1:68.8.0-1~deb8u1DLA-2206-1
thunderbirdsourcestretch1:68.8.0-1~deb9u1DSA-4683-1
thunderbirdsourcebuster1:68.8.0-1~deb10u1DSA-4683-1
thunderbirdsource(unstable)1:68.8.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2020-16/#CVE-2020-12387
https://www.mozilla.org/en-US/security/advisories/mfsa2020-17/#CVE-2020-12387
https://www.mozilla.org/en-US/security/advisories/mfsa2020-18/#CVE-2020-12387

Search for package or bug name: Reporting problems