CVE-2020-12401

NameCVE-2020-12401
DescriptionDuring ECDSA signature generation, padding applied in the nonce designed to ensure constant-time scalar multiplication was removed, resulting in variable-time execution dependent on secret data. This vulnerability affects Firefox < 80 and Firefox for Android < 80.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2388-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid82.0-1fixed
nss (PTS)stretch2:3.26.2-1.1+deb9u1vulnerable
stretch (security)2:3.26.2-1.1+deb9u2fixed
buster, buster (security)2:3.42.1-1+deb10u3vulnerable
bullseye, sid2:3.58-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)80.0-1
nsssourcestretch2:3.26.2-1.1+deb9u2DLA-2388-1
nsssource(unstable)2:3.55-1

Notes

[buster] - nss <no-dsa> (Minor issue)
https://hg.mozilla.org/projects/nss/rev/aeb2e583ee957a699d949009c7ba37af76515c20
https://bugzilla.mozilla.org/show_bug.cgi?id=1631573 (private)
https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.55_release_notes
https://www.mozilla.org/en-US/security/advisories/mfsa2020-36/#CVE-2020-12401

Search for package or bug name: Reporting problems