CVE-2020-12417

NameCVE-2020-12417
DescriptionDue to confusion about ValueTags on JavaScript Objects, an object may pass through the type barrier, resulting in memory corruption and a potentially exploitable crash. *Note: this issue only affects Firefox on ARM64 platforms.* This vulnerability affects Firefox ESR < 68.10, Firefox < 78, and Thunderbird < 68.10.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4713-1, DSA-4718-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid92.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1fixed
stretch (security)78.14.0esr-1~deb9u1fixed
buster78.11.0esr-1~deb10u1fixed
buster (security)78.14.0esr-1~deb10u1fixed
bullseye78.12.0esr-1fixed
bullseye (security)78.14.0esr-1~deb11u1fixed
bookworm78.13.0esr-1fixed
sid78.14.0esr-1fixed
thunderbird (PTS)stretch1:68.10.0-1~deb9u1fixed
stretch (security)1:78.14.0-1~deb9u1fixed
buster1:78.6.0-1~deb10u1fixed
buster (security)1:78.14.0-1~deb10u1fixed
bullseye1:78.12.0-1fixed
bullseye (security)1:78.14.0-1~deb11u1fixed
bookworm1:78.13.0-1fixed
sid1:78.14.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)78.0-1
firefox-esrsourcestretch68.10.0esr-1~deb9u1DSA-4713-1
firefox-esrsourcebuster68.10.0esr-1~deb10u1DSA-4713-1
firefox-esrsource(unstable)68.10.0esr-1
thunderbirdsourcestretch1:68.10.0-1~deb9u1DSA-4718-1
thunderbirdsourcebuster1:68.10.0-1~deb10u1DSA-4718-1
thunderbirdsource(unstable)1:68.10.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2020-24/#CVE-2020-12417
https://www.mozilla.org/en-US/security/advisories/mfsa2020-25/#CVE-2020-12417
https://www.mozilla.org/en-US/security/advisories/mfsa2020-26/#CVE-2020-12417

Search for package or bug name: Reporting problems