CVE-2020-12625

NameCVE-2020-12625
DescriptionAn issue was discovered in Roundcube Webmail before 1.4.4. There is a cross-site scripting (XSS) vulnerability in rcube_washtml.php because JavaScript code can occur in the CDATA of an HTML message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4674-1
NVD severitymedium
Debian Bugs959140

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
roundcube (PTS)stretch1.2.3+dfsg.1-4+deb9u3vulnerable
stretch (security)1.2.3+dfsg.1-4+deb9u4fixed
buster1.3.10+dfsg.1-1~deb10u1vulnerable
buster (security)1.3.11+dfsg.1-1~deb10u1fixed
bullseye1.4.5+dfsg.1-1fixed
sid1.4.5+dfsg.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
roundcubesource(unstable)1.4.4+dfsg.1-1959140
roundcubesourcebuster1.3.11+dfsg.1-1~deb10u1DSA-4674-1
roundcubesourcestretch1.2.3+dfsg.1-4+deb9u4DSA-4674-1

Notes

1.4.x: https://github.com/roundcube/roundcubemail/commit/87e4cd0cf2c550e77586860b94e5c75d2b7686d0
1.3.x: https://github.com/roundcube/roundcubemail/commit/23c06159ae8c6f500336e3075820e648aa6f40a4
1.2.x: https://github.com/roundcube/roundcubemail/commit/4312dc4efecb9553fcacfab0ab9d9ee6e88477e7

Search for package or bug name: Reporting problems