CVE-2020-12672

NameCVE-2020-12672
DescriptionGraphicsMagick through 1.3.35 has a heap-based buffer overflow in ReadMNGImage in coders/png.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs960000

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u2vulnerable
jessie (security)1.3.20-3+deb8u10vulnerable
stretch1.3.30+hg15796-1~deb9u2vulnerable
stretch (security)1.3.30+hg15796-1~deb9u4vulnerable
buster1.4~hg15978-1+deb10u1vulnerable
buster (security)1.4+really1.3.35-1~deb10u1vulnerable
bullseye, sid1.4+really1.3.35-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.4+really1.3.35-2960000

Notes

[buster] - graphicsmagick <postponed> (Minor issue; can be fixed along in future DSA)
[stretch] - graphicsmagick <postponed> (Minor issue; can be fixed along in future DSA)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=19025
Fixed by: https://sourceforge.net/p/graphicsmagick/code/ci/50395430a37188d0d197e71bd85ed6dd0f649ee3/

Search for package or bug name: Reporting problems