CVE-2020-12823

NameCVE-2020-12823
DescriptionOpenConnect 8.09 has a buffer overflow, causing a denial of service (application crash) or possibly unspecified other impact, via crafted certificate data to get_cert_name in gnutls.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2212-1
NVD severityhigh
Debian Bugs960620

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openconnect (PTS)stretch (security), stretch7.08-1+deb9u1vulnerable
buster, buster (security)8.02-1+deb10u1vulnerable
bullseye8.10-1fixed
sid8.10-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openconnectsourcejessie6.00-2+deb8u2DLA-2212-1
openconnectsource(unstable)8.10-1unimportant960620

Notes

https://gitlab.com/openconnect/openconnect/-/merge_requests/108
Only triggerable by local certs, which are under the control of the user

Search for package or bug name: Reporting problems