CVE-2020-12825

NameCVE-2020-12825
Descriptionlibcroco through 0.6.13 has excessive recursion in cr_parser_parse_any_core in cr-parser.c, leading to stack consumption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs960527

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcroco (PTS)jessie0.6.8-3vulnerable
stretch0.6.11-3vulnerable
buster0.6.12-3vulnerable
bullseye, sid0.6.13-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcrocosource(unstable)(unfixed)low960527

Notes

[buster] - libcroco <ignored> (Minor issue)
[stretch] - libcroco <ignored> (Minor issue)
[jessie] - libcroco <ignored> (Minor issue)
https://gitlab.gnome.org/GNOME/libcroco/-/issues/8

Search for package or bug name: Reporting problems