CVE-2020-12861

NameCVE-2020-12861
DescriptionA heap buffer overflow in SANE Backends before 1.0.30 allows a malicious device connected to the same local network as the victim to execute arbitrary code, aka GHSL-2020-080.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs961302

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sane-backends (PTS)stretch1.0.25-4.1vulnerable
bullseye, sid, buster1.0.27-3.2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sane-backendssourceexperimental1.0.30-1~experimental1
sane-backendssourcejessie(not affected)
sane-backendssource(unstable)(unfixed)961302

Notes

[buster] - sane-backends <no-dsa> (Minor issue)
[jessie] - sane-backends <not-affected> (epsonds backend was added in 1.0.25)
https://gitlab.com/sane-project/backends/-/issues/279
https://gitlab.com/sane-project/backends/-/issues/279#issue-3-ghsl-2020-080-heap-buffer-overflow-in-epsonds_net_read
https://alioth-lists.debian.net/pipermail/sane-announce/2020/000041.html

Search for package or bug name: Reporting problems