DescriptionA heap buffer overflow in SANE Backends before 1.0.30 may allow a malicious device connected to the same local network as the victim to execute arbitrary code, aka GHSL-2020-084.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs961302

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sane-backends (PTS)stretch1.0.25-4.1vulnerable
bullseye, sid, buster1.0.27-3.2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sane-backendssourcejessie(not affected)


[buster] - sane-backends <no-dsa> (Minor issue)
[jessie] - sane-backends <not-affected> (epsonds backend was added in 1.0.25)

Search for package or bug name: Reporting problems