CVE-2020-12867

NameCVE-2020-12867
DescriptionA NULL pointer dereference in sanei_epson_net_read in SANE Backends before 1.0.30 allows a malicious device connected to the same local network as the victim to cause a denial of service, aka GHSL-2020-075.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2231-1, DLA-2332-1
NVD severitylow
Debian Bugs961302

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sane-backends (PTS)stretch1.0.25-4.1vulnerable
stretch (security)1.0.25-4.1+deb9u2fixed
buster1.0.27-3.2vulnerable
bullseye, sid1.0.31-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sane-backendssourceexperimental1.0.30-1~experimental1
sane-backendssourcejessie1.0.24-8+deb8u3DLA-2231-1
sane-backendssourcestretch1.0.25-4.1+deb9u1DLA-2332-1
sane-backendssource(unstable)(unfixed)961302

Notes

[buster] - sane-backends <no-dsa> (Minor issue)
https://gitlab.com/sane-project/backends/-/issues/279
https://gitlab.com/sane-project/backends/-/issues/279#issue-1-ghsl-2020-075-null-pointer-dereference-in-sanei_epson_net_read
https://alioth-lists.debian.net/pipermail/sane-announce/2020/000041.html
https://gitlab.com/sane-project/backends/-/commit/fff83e7eacd0f27bb2d71c42488e0fd735c15ac3 (1.0.30)

Search for package or bug name: Reporting problems