Descriptionyaws_config.erl in Yaws through 2.0.2 and/or 2.0.7 loads obsolete TLS ciphers, as demonstrated by ones that allow Sweet32 attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
erlang (PTS)stretch1:19.2.1+dfsg-2+deb9u2vulnerable
stretch (security)1:19.2.1+dfsg-2+deb9u1vulnerable
bullseye, sid1:23.0.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[stretch] - erlang <no-dsa> (Minor issue)
[jessie] - erlang <no-dsa> (Minor issue)
In Debian yaws uses the cipher settings from erlang, mark the version which
landed in Buster as fixed (although it was possibly fixed earlier between
Stretch and Buster. The CVE was assigned specifically for yaws, cf. #961422
for discussion.

Search for package or bug name: Reporting problems