CVE-2020-12872

NameCVE-2020-12872
Descriptionyaws_config.erl in Yaws through 2.0.2 and/or 2.0.7 loads obsolete TLS ciphers, as demonstrated by ones that allow Sweet32 attacks, if running on an Erlang/OTP virtual machine with a version less than 21.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
erlang (PTS)buster1:21.2.6+dfsg-1fixed
buster (security)1:22.2.7+dfsg-1+deb10u1fixed
bullseye1:23.2.6+dfsg-1+deb11u1fixed
bookworm1:25.2.3+dfsg-1fixed
sid, trixie1:25.3.2.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
erlangsourcestretch1:19.2.1+dfsg-2+deb9u3
erlangsource(unstable)1:21.2.6+dfsg-1low

Notes

[jessie] - erlang <no-dsa> (Minor issue)
https://medium.com/@charlielabs101/cve-2020-12872-df315411aa70
https://github.com/erlyaws/yaws/issues/402
In Debian yaws uses the cipher settings from erlang, mark the version which
landed in Buster as fixed (although it was possibly fixed earlier between
Stretch and Buster. The CVE was assigned specifically for yaws, cf. #961422
for discussion.

Search for package or bug name: Reporting problems