CVE-2020-13614

NameCVE-2020-13614
DescriptionAn issue was discovered in ssl.c in Axel before 2.17.8. The TLS implementation lacks hostname verification.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
axel (PTS)stretch2.12-1vulnerable
buster2.16.1-4vulnerable
bullseye, sid2.17.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
axelsourcejessie(not affected)
axelsource(unstable)2.17.8-1

Notes

[buster] - axel <no-dsa> (Minor issue)
[stretch] - axel <no-dsa> (Minor issue)
[jessie] - axel <not-affected> (SSL/TLS implemented from v2.10. But without ssl support is a major drawback)
https://github.com/axel-download-accelerator/axel/issues/262

Search for package or bug name: Reporting problems