CVE-2020-13692

NameCVE-2020-13692
DescriptionPostgreSQL JDBC Driver (aka PgJDBC) before 42.2.13 allows XXE.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs962828

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpgjava (PTS)stretch9.4.1212-1vulnerable
stretch (security)9.4.1212-1+deb9u1vulnerable
buster42.2.5-2vulnerable
bullseye42.2.15-1fixed
bookworm, sid42.4.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpgjavasource(unstable)42.2.12-2low962828

Notes

[buster] - libpgjava <no-dsa> (Minor issue)
[stretch] - libpgjava <no-dsa> (Minor issue)
[jessie] - libpgjava <no-dsa> (Minor issue)
https://github.com/pgjdbc/pgjdbc/commit/14b62aca4764d496813f55a43d050b017e01eb65

Search for package or bug name: Reporting problems