CVE-2020-13956

NameCVE-2020-13956
DescriptionApache HttpClient versions prior to version 4.5.13 and 5.0.3 can misinterpret malformed authority component in request URIs passed to the library as java.net.URI object and pick the wrong target host for request execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2405-1, DSA-4772-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
httpcomponents-client (PTS)stretch4.5.2-2vulnerable
stretch (security)4.5.2-2+deb9u1fixed
buster, buster (security)4.5.7-1+deb10u1fixed
bullseye4.5.13-2fixed
bookworm, sid4.5.13-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
httpcomponents-clientsourcestretch4.5.2-2+deb9u1DLA-2405-1
httpcomponents-clientsourcebuster4.5.7-1+deb10u1DSA-4772-1
httpcomponents-clientsource(unstable)4.5.13-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1886587
Fixed by: https://github.com/apache/httpcomponents-client/commit/e628b4c5c464c2fa346385596cc78e035a91a62e (4.5.13-RC1)

Search for package or bug name: Reporting problems