CVE-2020-14147

NameCVE-2020-14147
DescriptionAn integer overflow in the getnum function in lua_struct.c in Redis before 6.0.3 allows context-dependent attackers with permission to run Lua code in a Redis session to cause a denial of service (memory corruption and application crash) or possibly bypass intended sandbox restrictions via a large number, which triggers a stack-based buffer overflow. NOTE: this issue exists because of a CVE-2015-8080 regression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4731-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redis (PTS)stretch (security), stretch3:3.2.6-3+deb9u3fixed
buster, buster (security)5:5.0.3-4+deb10u2fixed
bullseye, sid5:6.0.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redissourcejessie(not affected)
redissourcestretch(not affected)
redissourcebuster5:5.0.3-4+deb10u2DSA-4731-1
redissource(unstable)5:6.0.0-1

Notes

[stretch] - redis <not-affected> (Vulnerable code reintroduced later)
[jessie] - redis <not-affected> (Vulnerable code reintroduced later)
https://github.com/antirez/redis/pull/6875
Issue re-introduced with https://github.com/antirez/redis/commit/1eb08bcd4634ae42ec45e8284923ac048beaa4c3 (5.0-rc4)
Fixed by: https://github.com/antirez/redis/commit/ef764dde1cca2f25d00686673d1bc89448819571
Fixed upstream in 6.0~rc2 and 5.0.8

Search for package or bug name: Reporting problems