CVE-2020-14148

NameCVE-2020-14148
DescriptionThe Server-Server protocol implementation in ngIRCd before 26~rc2 allows an out-of-bounds access, as demonstrated by the IRC_NJOIN() function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2252-1
NVD severitymedium
Debian Bugs963147

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ngircd (PTS)stretch24-1vulnerable
buster25-2vulnerable
bullseye, sid26-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ngircdsourcejessie22-2+deb8u1DLA-2252-1
ngircdsource(unstable)(unfixed)963147

Notes

[buster] - ngircd <no-dsa> (Minor issue)
[stretch] - ngircd <no-dsa> (Minor issue)
https://github.com/ngircd/ngircd/issues/274
https://github.com/ngircd/ngircd/issues/277
https://github.com/ngircd/ngircd/pull/275
https://github.com/ngircd/ngircd/pull/276
https://github.com/ngircd/ngircd/commit/02cf31c0e267a4c9a7656d43ad3ad4eeb37fc9c5

Search for package or bug name: Reporting problems