CVE-2020-14318

NameCVE-2020-14318
DescriptionA flaw was found in the way samba handled file and directory permissions. An authenticated user could use this flaw to gain access to certain file and directory information which otherwise would be unavailable to the attacker.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2463-1
Debian Bugs973400

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)stretch2:4.5.16+dfsg-1+deb9u2vulnerable
stretch (security)2:4.5.16+dfsg-1+deb9u4fixed
buster, buster (security)2:4.9.5+dfsg-5+deb10u3vulnerable
bullseye (security), bullseye2:4.13.13+dfsg-1~deb11u3fixed
bookworm, sid2:4.16.1+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourceexperimental2:4.13.2+dfsg-1
sambasourcestretch2:4.5.16+dfsg-1+deb9u3DLA-2463-1
sambasource(unstable)2:4.13.2+dfsg-2973400

Notes

[buster] - samba <no-dsa> (Minor issue)
https://www.samba.org/samba/security/CVE-2020-14318.html
https://bugzilla.samba.org/show_bug.cgi?id=14434

Search for package or bug name: Reporting problems