DescriptionA vulnerability was discovered in the PyYAML library in versions before 5.4, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. This flaw allows an attacker to execute arbitrary code on the system by abusing the python/object/new constructor. This flaw is due to an incomplete fix for CVE-2020-1747.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs966233

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pyyaml (PTS)bullseye5.3.1-5fixed
sid, trixie6.0.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pyyamlsourcestretch(not affected)
pyyamlsourcebuster(not affected)


[buster] - pyyaml <not-affected> (Vulnerable code not present)
[stretch] - pyyaml <not-affected> (Vulnerable code not present)
Fixed via:
CVE is for an incomplete fix of CVE-2020-1747.

Search for package or bug name: Reporting problems