CVE-2020-14343

NameCVE-2020-14343
DescriptionA vulnerability was discovered in the PyYAML library in versions before 5.4, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. This flaw allows an attacker to execute arbitrary code on the system by abusing the python/object/new constructor. This flaw is due to an incomplete fix for CVE-2020-1747.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs966233

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pyyaml (PTS)stretch3.12-1fixed
buster3.13-2fixed
bullseye, sid5.3.1-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pyyamlsourcestretch(not affected)
pyyamlsourcebuster(not affected)
pyyamlsource(unstable)(unfixed)966233

Notes

[buster] - pyyaml <not-affected> (Vulnerable code not present)
[stretch] - pyyaml <not-affected> (Vulnerable code not present)
https://github.com/yaml/pyyaml/issues/420
Fixed via: https://github.com/yaml/pyyaml/pull/472
https://github.com/yaml/pyyaml/commit/7adc0db3f613a82669f2b168edd98379b83adb3c
CVE is for an incomplete fix of CVE-2020-1747.

Search for package or bug name: Reporting problems