CVE-2020-14424

NameCVE-2020-14424
DescriptionCacti before 1.2.18 allows remote attackers to trigger XSS via template import for the midwinter theme.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u5fixed
bullseye (security), bullseye1.2.16+ds1-2+deb11u1fixed
bookworm, sid1.2.23+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcestretch(not affected)
cactisourcebuster(not affected)
cactisourcebullseye(not affected)
cactisource(unstable)1.2.19+ds1-1

Notes

[bullseye] - cacti <not-affected> (Vulnerable code not present)
[buster] - cacti <not-affected> (Vulnerable code not present)
[stretch] - cacti <not-affected> (Vulnerable code not present)
https://github.com/Cacti/cacti/pull/4261
https://github.com/Cacti/cacti/commit/d12800ab479ad95a091bc577f28fd99ec95eb64c (release/1.2.18)

Search for package or bug name: Reporting problems