CVE-2020-15011

NameCVE-2020-15011
DescriptionGNU Mailman before 2.1.33 allows arbitrary content injection via the Cgi/private.py private archive login page.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2265-1, DLA-2276-1, DSA-4991-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mailman (PTS)stretch1:2.1.23-1+deb9u5vulnerable
stretch (security)1:2.1.23-1+deb9u7fixed
buster1:2.1.29-1+deb10u1vulnerable
buster (security)1:2.1.29-1+deb10u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mailmansourcejessie1:2.1.18-2+deb8u7DLA-2265-1
mailmansourcestretch1:2.1.23-1+deb9u6DLA-2276-1
mailmansourcebuster1:2.1.29-1+deb10u2DSA-4991-1
mailmansource(unstable)(unfixed)

Notes

https://bugs.launchpad.net/mailman/+bug/1877379
Fixed by: https://bazaar.launchpad.net/~mailman-coders/mailman/2.1/revision/1848

Search for package or bug name: Reporting problems