CVE-2020-15115

NameCVE-2020-15115
Descriptionetcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users' passwords with little computational effort.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs968740

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
etcd (PTS)buster3.2.26+dfsg-3vulnerable
bullseye, sid3.3.25+dfsg-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
etcdsourceexperimental3.3.25+dfsg-1
etcdsource(unstable)3.3.25+dfsg-5968740

Notes

https://github.com/etcd-io/etcd/security/advisories/GHSA-4993-m7g5-r9hh

Search for package or bug name: Reporting problems