CVE-2020-15227

NameCVE-2020-15227
DescriptionNette versions before 2.0.19, 2.1.13, 2.2.10, 2.3.14, 2.4.16, 3.0.6 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE. Nette is a PHP/Composer MVC Framework.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2617-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-nette (PTS)stretch2.4-20160731-1vulnerable
stretch (security)2.4-20160731-1+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-nettesourcestretch2.4-20160731-1+deb9u1DLA-2617-1
php-nettesource(unstable)(unfixed)

Notes

https://github.com/nette/application/security/advisories/GHSA-8gv3-3j7f-wg94

Search for package or bug name: Reporting problems