CVE-2020-15238

NameCVE-2020-15238
DescriptionBlueman is a GTK+ Bluetooth Manager. In Blueman before 2.1.4, the DhcpClient method of the D-Bus interface to blueman-mechanism is prone to an argument injection vulnerability. The impact highly depends on the system configuration. If Polkit-1 is disabled and for versions lower than 2.0.6, any local user can possibly exploit this. If Polkit-1 is enabled for version 2.0.6 and later, a possible attacker needs to be allowed to use the `org.blueman.dhcp.client` action. That is limited to users in the wheel group in the shipped rules file that do have the privileges anyway. On systems with ISC DHCP client (dhclient), attackers can pass arguments to `ip link` with the interface name that can e.g. be used to bring down an interface or add an arbitrary XDP/BPF program. On systems with dhcpcd and without ISC DHCP client, attackers can even run arbitrary scripts by passing `-c/path/to/script` as an interface name. Patches are included in 2.1.4 and master that change the DhcpClient D-Bus method(s) to accept BlueZ network object paths instead of network interface names. A backport to 2.0(.8) is also available. As a workaround, make sure that Polkit-1-support is enabled and limit privileges for the `org.blueman.dhcp.client` action to users that are able to run arbitrary commands as root anyway in /usr/share/polkit-1/rules.d/blueman.rules.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2430-1, DSA-4781-1
NVD severitymedium
Debian Bugs973718

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
blueman (PTS)stretch2.0.4-1vulnerable
stretch (security)2.0.4-1+deb9u1fixed
buster2.0.8-1vulnerable
buster (security)2.0.8-1+deb10u1fixed
bullseye, sid2.1.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bluemansourcestretch2.0.4-1+deb9u1DLA-2430-1
bluemansourcebuster2.0.8-1+deb10u1DSA-4781-1
bluemansource(unstable)2.1.4-1973718

Notes

https://github.com/blueman-project/blueman/security/advisories/GHSA-jpc9-mgw6-2xwx
https://bugs.launchpad.net/ubuntu/+source/blueman/+bug/1897287
https://github.com/blueman-project/blueman/commit/02161d60e8e311b08fb18254615259085fcd6688
Additionally Build-Depends on libpolkit-agent-1-dev needed (blueman should
use polkit for authorisation but due to a packaging issue this was not
enabled).

Search for package or bug name: Reporting problems