CVE-2020-15305

NameCVE-2020-15305
DescriptionAn issue was discovered in OpenEXR before 2.5.2. Invalid input could cause a use-after-free in DeepScanLineInputFile::DeepScanLineInputFile() in IlmImf/ImfDeepScanLineInputFile.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openexr (PTS)stretch2.2.0-11vulnerable
buster2.2.1-4.1vulnerable
bullseye, sid2.3.0-6vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openexrsourceexperimental2.5.2-1
openexrsource(unstable)(unfixed)

Notes

[jessie] - openexr <no-dsa> (Minor issue)
https://github.com/AcademySoftwareFoundation/openexr/pull/730

Search for package or bug name: Reporting problems