CVE-2020-15366

NameCVE-2020-15366
DescriptionAn issue was discovered in ajv.validate() in Ajv (aka Another JSON Schema Validator) 6.12.2. A carefully crafted JSON schema could be provided that allows execution of other code by prototype pollution. (While untrusted schemas are recommended against, the worst case of an untrusted schema should be a denial of service, not execution of code.)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-ajv (PTS)buster5.0.0-1vulnerable
bullseye, sid6.12.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-ajvsource(unstable)6.12.4-1

Notes

[buster] - node-ajv <no-dsa> (Minor issue)
https://github.com/ajv-validator/ajv/releases/tag/v6.12.3

Search for package or bug name: Reporting problems