CVE-2020-15400

NameCVE-2020-15400
DescriptionCakePHP before 4.0.6 mishandles CSRF token generation. This might be remotely exploitable in conjunction with XSS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cakephp (PTS)stretch2.8.5-1vulnerable
bullseye, sid, buster2.10.11-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cakephpsource(unstable)(unfixed)

Notes

[buster] - cakephp <no-dsa> (Minor issue)
[stretch] - cakephp <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems