CVE-2020-15436

NameCVE-2020-15436
DescriptionUse-after-free vulnerability in fs/block_dev.c in the Linux kernel before 5.8 allows local users to gain privileges or cause a denial of service by leveraging improper access to a certain error field.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1vulnerable
stretch (security)4.9.258-1fixed
buster4.19.181-1fixed
buster (security)4.19.171-2fixed
bullseye, sid5.10.28-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcestretch4.9.240-1
linuxsourcebuster4.19.131-1
linuxsource(unstable)5.7.6-1

Notes

https://git.kernel.org/linus/2d3a8e2deddea6c89961c422ec0c5b851e648c14

Search for package or bug name: Reporting problems