CVE-2020-15471

NameCVE-2020-15471
DescriptionIn nDPI through 3.2, the packet parsing code is vulnerable to a heap-based buffer over-read in ndpi_parse_packet_line_info in lib/ndpi_main.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs972050

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ndpi (PTS)stretch1.8-1fixed
stretch (security)1.8-1+deb9u1fixed
buster2.6-3fixed
sid3.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ndpisourcestretch(not affected)
ndpisourcebuster(not affected)
ndpisource(unstable)(unfixed)972050

Notes

[buster] - ndpi <not-affected> (Vulnerable code not present)
[stretch] - ndpi <not-affected> (Vulnerable code not present)
https://github.com/ntop/nDPI/commit/61066fb106efa6d3d95b67e47b662de208b2b622

Search for package or bug name: Reporting problems