CVE-2020-15473

NameCVE-2020-15473
DescriptionIn nDPI through 3.2, the OpenVPN dissector is vulnerable to a heap-based buffer over-read in ndpi_search_openvpn in lib/protocols/openvpn.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs972050

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ndpi (PTS)stretch1.8-1fixed
stretch (security)1.8-1+deb9u1fixed
buster2.6-3vulnerable
sid3.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ndpisourcestretch(not affected)
ndpisource(unstable)(unfixed)972050

Notes

[stretch] - ndpi <not-affected> (Vulnerable code introduced later)
https://github.com/ntop/nDPI/commit/8e7b1ea7a136cc4e4aa9880072ec2d69900a825e

Search for package or bug name: Reporting problems