CVE-2020-15586

NameCVE-2020-15586
DescriptionGo before 1.13.13 and 1.14.x before 1.14.5 has a data race in some net/http servers, as demonstrated by the httputil.ReverseProxy Handler, because it reads a request body and writes a response at the same time.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-1.11 (PTS)buster, buster (security)1.11.6-1+deb10u3vulnerable
golang-1.14 (PTS)bullseye1.14.4-2vulnerable
sid1.14.7-2fixed
golang-1.15 (PTS)bullseye1.15~beta1-2vulnerable
sid1.15~rc2-1fixed
golang-1.7 (PTS)stretch (security), stretch1.7.4-2+deb9u1vulnerable
golang-1.8 (PTS)stretch (security), stretch1.8.1-1+deb9u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golangsource(unstable)(unfixed)
golang-1.11source(unstable)(unfixed)
golang-1.14source(unstable)1.14.6-1
golang-1.15source(unstable)1.15~rc1-1
golang-1.7source(unstable)(unfixed)
golang-1.8source(unstable)(unfixed)

Notes

[buster] - golang-1.11 <postponed> (Minor issue, can be fixed along in next DSA)
https://github.com/golang/go/issues/34902
https://groups.google.com/g/golang-announce/c/XZNfaiwgt2w/m/E6gHDs32AQAJ

Search for package or bug name: Reporting problems