CVE-2020-15693

NameCVE-2020-15693
DescriptionIn Nim 1.2.4, the standard library httpClient is vulnerable to a CR-LF injection in the target URL. An injection is possible if the attacker controls any part of the URL provided in a call (such as httpClient.get or httpClient.post), the User-Agent header value, or custom HTTP header names or values.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nim (PTS)stretch0.16.0-1vulnerable
buster0.19.4-1vulnerable
bullseye1.2.6-1fixed
sid1.4.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nimsource(unstable)1.2.6-1

Notes

[buster] - nim <no-dsa> (Minor issue)
[stretch] - nim <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems