CVE-2020-15694

NameCVE-2020-15694
DescriptionIn Nim 1.2.4, the standard library httpClient fails to properly validate the server response. For example, httpClient.get().contentLength() does not raise any error if a malicious server provides a negative Content-Length.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nim (PTS)stretch0.16.0-1vulnerable
buster0.19.4-1vulnerable
bullseye1.2.6-1fixed
sid1.4.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nimsource(unstable)1.2.6-1

Notes

[buster] - nim <no-dsa> (Minor issue)
[stretch] - nim <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems