CVE-2020-15861

NameCVE-2020-15861
DescriptionNet-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink) following.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2313-1, DSA-4746-1
NVD severityhigh
Debian Bugs966599

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
net-snmp (PTS)stretch5.7.3+dfsg-1.7+deb9u1vulnerable
stretch (security)5.7.3+dfsg-1.7+deb9u3fixed
buster, buster (security)5.7.3+dfsg-5+deb10u1fixed
bullseye, sid5.9+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
net-snmpsourcestretch5.7.3+dfsg-1.7+deb9u3DLA-2313-1
net-snmpsourcebuster5.7.3+dfsg-5+deb10u1DSA-4746-1
net-snmpsource(unstable)5.8+dfsg-5966599

Notes

https://github.com/net-snmp/net-snmp/issues/145
https://github.com/net-snmp/net-snmp/commit/4fd9a450444a434a993bc72f7c3486ccce41f602

Search for package or bug name: Reporting problems