CVE-2020-15889

NameCVE-2020-15889
DescriptionLua through 5.4.0 has a getobjname heap-based buffer over-read because youngcollection in lgc.c uses markold for an insufficient number of list members.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lua5.4 (PTS)bullseye, sid5.4.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lua5.4source(unstable)5.4.0-2

Notes

http://lua-users.org/lists/lua-l/2020-07/msg00078.html
https://github.com/lua/lua/commit/127e7a6c8942b362aa3c6627f44d660a4fb75312
Introduced in 5.4

Search for package or bug name: Reporting problems