CVE-2020-15953

NameCVE-2020-15953
DescriptionLibEtPan through 1.9.4, as used in MailCore 2 through 0.6.3 and other products, has a STARTTLS buffering issue that affects IMAP, SMTP, and POP3. When a server sends a "begin TLS" response, the client reads additional data (e.g., from a meddler-in-the-middle attacker) and evaluates it in a TLS context, aka "response injection."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2329-1
NVD severitymedium
Debian Bugs966647

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libetpan (PTS)stretch1.6-3vulnerable
stretch (security)1.6-3+deb9u1fixed
buster1.9.3-2vulnerable
bullseye, sid1.9.4-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libetpansourcestretch1.6-3+deb9u1DLA-2329-1
libetpansource(unstable)(unfixed)966647

Notes

[buster] - libetpan <no-dsa> (Minor issue)
https://github.com/dinhvh/libetpan/issues/386
https://github.com/dinhvh/libetpan/pull/387
https://github.com/dinhvh/libetpan/pull/388

Search for package or bug name: Reporting problems