CVE-2020-16044

NameCVE-2020-16044
DescriptionUse after free in WebRTC in Google Chrome prior to 88.0.4324.96 allowed a remote attacker to potentially exploit heap corruption via a crafted SCTP packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2521-1, DLA-2541-1, DSA-4827-1, DSA-4842-1, DSA-4846-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium (PTS)buster88.0.4324.182-1~deb10u1fixed
buster (security)89.0.4389.114-1~deb10u1fixed
firefox (PTS)sid88.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1vulnerable
stretch (security)78.9.0esr-1~deb9u1fixed
buster78.8.0esr-1~deb10u1fixed
buster (security)78.9.0esr-1~deb10u1fixed
bullseye78.9.0esr-1fixed
sid78.10.0esr-1fixed
thunderbird (PTS)stretch1:68.10.0-1~deb9u1vulnerable
stretch (security)1:78.9.0-1~deb9u1fixed
buster1:78.6.0-1~deb10u1vulnerable
buster (security)1:78.9.0-1~deb10u1fixed
bullseye, sid1:78.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromiumsourcebuster88.0.4324.146-1~deb10u1DSA-4846-1
firefoxsource(unstable)84.0.2-1
firefox-esrsourcestretch78.6.1esr-1~deb9u1DLA-2521-1
firefox-esrsourcebuster78.6.1esr-1~deb10u1DSA-4827-1
firefox-esrsource(unstable)78.6.1esr-1
thunderbirdsourcestretch1:78.7.0-1~deb9u1DLA-2541-1
thunderbirdsourcebuster1:78.7.0-1~deb10u1DSA-4842-1
thunderbirdsource(unstable)1:78.6.1-1

Notes

[stretch] - thunderbird <postponed> (Minor issue, wait until next Mozilla security cycle)
https://www.mozilla.org/en-US/security/advisories/mfsa2021-01/#CVE-2020-16044
https://www.mozilla.org/en-US/security/advisories/mfsa2021-02/#CVE-2020-16044

Search for package or bug name: Reporting problems