CVE-2020-16117

NameCVE-2020-16117
DescriptionIn GNOME evolution-data-server before 3.35.91, a malicious server can crash the mail client with a NULL pointer dereference by sending an invalid (e.g., minimal) CAPABILITY line on a connection attempt. This is related to imapx_free_capability and imapx_connect_to_server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2309-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
evolution-data-server (PTS)buster3.30.5-1+deb10u2fixed
buster (security)3.30.5-1+deb10u1vulnerable
bullseye3.38.3-1+deb11u2fixed
bookworm3.46.4-2fixed
sid3.48.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
evolution-data-serversourcestretch3.22.7-1+deb9u2DLA-2309-1
evolution-data-serversourcebuster3.30.5-1+deb10u2
evolution-data-serversource(unstable)3.36.0-1

Notes

https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/2cc39592b532cf0dc994fd3694b8e6bf924c9ab5
https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/627c3cdbfd077e59aa288c85ff8272950577f1d7
https://gitlab.gnome.org/GNOME/evolution-data-server/-/issues/189

Search for package or bug name: Reporting problems