CVE-2020-16122

NameCVE-2020-16122
DescriptionPackageKit's apt backend mistakenly treated all local debs as trusted. The apt security model is based on repository trust and not on the contents of individual files. On sites with configured PolicyKit rules this may allow users to install malicious packages.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2399-1
NVD severitylow
Debian Bugs972229

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
packagekit (PTS)stretch1.1.5-2+deb9u1vulnerable
stretch (security)1.1.5-2+deb9u2fixed
buster1.1.12-5vulnerable
bullseye, sid1.2.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
packagekitsourcestretch1.1.5-2+deb9u2DLA-2399-1
packagekitsource(unstable)1.2.1-1972229

Notes

[buster] - packagekit <no-dsa> (Minor issue)
https://bugs.launchpad.net/ubuntu/+source/packagekit/+bug/1882098

Search for package or bug name: Reporting problems