CVE-2020-16305

NameCVE-2020-16305
DescriptionA buffer overflow vulnerability in pcx_write_rle() in contrib/japanese/gdev10v.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2335-1, DSA-4748-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)stretch9.26a~dfsg-0+deb9u6vulnerable
stretch (security)9.26a~dfsg-0+deb9u7fixed
buster, buster (security)9.27~dfsg-2+deb10u4fixed
bullseye9.52.1~dfsg-1fixed
sid9.53.2~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsourcestretch9.26a~dfsg-0+deb9u7DLA-2335-1
ghostscriptsourcebuster9.27~dfsg-2+deb10u4DSA-4748-1
ghostscriptsource(unstable)9.51~dfsg-1

Notes

https://bugs.ghostscript.com/show_bug.cgi?id=701819
https://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=2793769ff107d8d22dadd30c6e68cd781b569550 (9.51)

Search for package or bug name: Reporting problems