CVE-2020-16587

NameCVE-2020-16587
DescriptionA heap-based buffer overflow vulnerability exists in Academy Software Foundation OpenEXR 2.3.0 in chunkOffsetReconstruction in ImfMultiPartInputFile.cpp that can cause a denial of service via a crafted EXR file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openexr (PTS)stretch2.2.0-11fixed
stretch (security)2.2.0-11+deb9u2fixed
buster, buster (security)2.2.1-4.1+deb10u1vulnerable
bullseye, sid2.5.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openexrsourcestretch(not affected)
openexrsource(unstable)2.5.3-2

Notes

[stretch] - openexr <not-affected> (Vulnerable code not present, part number range checking added later)
https://github.com/AcademySoftwareFoundation/openexr/commit/8b5370c688a7362673c3a5256d93695617a4cd9a (v2.4.0-beta.1)
https://github.com/AcademySoftwareFoundation/openexr/issues/491

Search for package or bug name: Reporting problems