CVE-2020-1711

NameCVE-2020-1711
DescriptionAn out-of-bounds heap buffer access flaw was found in the way the iSCSI Block driver in QEMU versions 2.12.0 before 4.2.1 handled a response coming from an iSCSI server while checking the status of a Logical Address Block (LBA) in an iscsi_co_block_status() routine. A remote user could use this flaw to crash the QEMU process, resulting in a denial of service or potential execution of arbitrary code with privileges of the QEMU process on the host.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2144-1
NVD severitymedium
Debian Bugs949731

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)stretch1:2.8+dfsg-6+deb9u9vulnerable
stretch (security)1:2.8+dfsg-6+deb9u10vulnerable
buster, buster (security)1:3.1+dfsg-8+deb10u7fixed
bullseye1:5.0-13fixed
sid1:5.0-14fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcejessie1:2.1+dfsg-12+deb8u14DLA-2144-1
qemusourcebuster1:3.1+dfsg-8+deb10u4
qemusource(unstable)1:4.2-2949731
qemu-kvmsource(unstable)(unfixed)

Notes

[stretch] - qemu <postponed> (Intrusive to backport, revisit later)
Upstream patch: https://lists.gnu.org/archive/html/qemu-devel/2020-01/msg05535.html
https://www.openwall.com/lists/oss-security/2020/01/23/3

Search for package or bug name: Reporting problems